BlueGriffon, HTML Jquery, librerie Giochi, Blogger, Templates Blogger, widget, gadget, aspetto QR, codice, Blogger AdWords, Google, pubblicità Templates, Blogger, Natura Nlogger, templates, Manga

Come aggiornare JQuery per far funzionare tutti i widget.

La incompatibilità di menù e widget con il modello e con altre personalizzazioni già installate è una cosa che infastidisce particolarmente. La libreria più usata per questi effetti è quella JQuery che offre una gran quantità di plugin.

jQuery è una libreria di funzioni Javascript per le applicazioni web, che si propone come obiettivo quello di semplificare la manipolazione, la gestione degli eventi e l'animazione delle pagine HTML. È un software liberamente distribuibile e gratuito, come previsto dalla licenza MIT.

Pubblicato per la prima volta nel gennaio 2006 da John Resig, è un progetto tuttora attivo ed in evoluzione, gestito da un gruppo di sviluppatori guidato da Dave Methvin.

 

jQuery

Attualmente, anche Microsoft e Nokia forniscono di serie jQuery sulle proprie piattaforme. Microsoft lo fornisce con le più recenti versioni di Visual Studio per semplificare lo sviluppo di pagine ASP.NET AJAX e ASP.NET MVC, mentre Nokia le ha integrate nel proprio widget di runtime web.

La sintassi di jQuery è studiata per semplificare la navigazione dei documenti, la selezione degli elementi DOM, creare animazioni, gestire eventi e implementare funzionalità AJAX.

Se avete una libreria JQuery installata nel vostro modello è opportuno quindi che la aggiorniate da soli per avere una maggiore compatibilità e anche per migliorare le prestazioni del sito. Nel momento in cui aggiorno questo articolo la libreria JQuery più recente si trova a questo indirizzo 

1.x snippet: <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>
2.x snippet: <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.3/jquery.min.js"></script>
site: jquery.com
versions: 2.1.3, 2.1.1, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.11.2, 1.11.1, 1.11.0, 1.10.2, 1.10.1, 1.10.0, 1.9.1, 1.9.0, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7.0, 1.6.4, 1.6.3, 1.6.2, 1.6.1, 1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.0, 1.2.6, 1.2.3
note: 2.1.2, 1.2.5 and 1.2.4 are not hosted due to their short and unstable lives in the wild.

e in genere viene inserita nel blog sopra la riga </head> con questa sintassi

<script src='//ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js' type='text/javascript'/>

Può darsi che nel vostro modello esistano versioni precedenti o addirittura che convivano più versioni. Le operazioni che si devono compiere per migliorare le prestazioni del sito e per migliorare le sue performance sono quelle di

  1. Eliminare le righe simili se sono state usate per più widget, basta caricarne una soltanto. Versioni diverse di JQuery presenti nello stesso template sono la ragione principale delle incompatibilità tra widget.

  2. Aggiornare l'URL di JQuery all'ultima versione

  3. Per vedere quale è l'ultima versione disponibile si accede alle API di Google. L'indirizzo si trova anche nella riga Path:

  4. Con questo metodo si possono aggiornare anche le librerie di Prototype, Scriptaculous e degli oggetti in flash (SWFObject)

Se ti è piaciuto l'articolo , iscriviti al feed cliccando sull'immagine sottostante per tenerti sempre aggiornato sui nuovi contenuti del blog:

Come aggiornare JQuery per far funzionare tutti i widget. Come aggiornare JQuery per far funzionare tutti i widget. Reviewed by Luca Soraci on gennaio 14, 2015 Rating: 5

Trovato questo articolo interessante? Condividilo sulla tua rete di contatti Twitter, sulla tua bacheca su Facebook o semplicemente premi "+1" per suggerire questo risultato nelle ricerche in Google, Linkedin, Instagram o Pinterest. Diffondere contenuti che trovi rilevanti aiuta questo blog a crescere. Grazie! CONDIVIDI SU!!

Nessun commento